TeleVoIPs Status - Inbound email outage – Incident details

All systems operational

Inbound email outage

Resolved
Partial outage
Started about 2 months agoLasted about 18 hours

Affected

Helpdesk

Partial outage from 7:30 PM to 1:00 PM

Updates
  • Resolved
    Resolved

    All systems are normal, this incident is resolved.

  • Update
    Update

    Inbound and Outbound email has returned to normal. From Microsoft Jan 23, 2026, 1:27 AM EST: We’ve confirmed that the affected infrastructure has returned to a healthy state and is operating as expected. We’ll continue to closely monitor the remediation actions taken and make any necessary adjustments to maintain stability.

  • Update
    Update

    We are seeing emails start to trickle in. Microsoft's current status is still degraded. Microsoft: We're continuing to refine our load balancing configurations to remedy residual imbalances across the environment and further our ongoing recovery efforts.

  • Update
    Update

    From Microsoft: Current status: While we've restored the affected infrastructure to a heathy state, further load balancing is required to mitigate persistent impact. We've identified and are implementing additional actions to direct requests and traffic to additional healthy sections of infrastructure to achieve withstanding recovery. During this time please call our support desk at 8136555100 option 2 until this is resolved.

  • Investigating
    Investigating

    Microsoft is reporting Degraded Performance sending and receiving email through Exchange Online. This is affecting our email helpdesk.